Browser streaming issues on Google Chrome 124 and Microsoft Edge 124
Incident Report for Innoactive Portal
Resolved
We've updated our service globally to restore support for all browsers including Google Chrome and Microsoft Edge 124.

While most of the updates should have been applied already, please note that it may take up to two hours for already running cloud-rendering infrastructure to receive the updates.
Posted Apr 24, 2024 - 11:59 UTC
Monitoring
We have implemented a fix to address the issue and restore full browser support. The fix is gradually being rolled out to all instances and organizations while we monitor the issue.
Posted Apr 24, 2024 - 07:01 UTC
Identified
We have identified the issue to affect the most recent versions of Google Chrome and Microsoft Edge browsers (Version 124) and are working on a fix. Other browsers and older versions of Google Chrome / Microsoft Edge are unaffected.
Posted Apr 23, 2024 - 12:51 UTC
Investigating
We are currently investigating an increased number of "Connection failed" issues in sessions streamed to the Browser.
Posted Apr 23, 2024 - 12:49 UTC
This incident affected: Cloud Rendering Service.